Open Forum

 View Only

Printing Problems

  • 1.  Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 09, 2021 08:58 AM
    Hi,

    I have a rather unusual issue where one user, on one workstation is having problems to print most reports in Dynamics SL.  They reported that they could print from another workstation and they are not getting any error message, as well as they could only print the 'Reprint AP Batch Control Report.

    Now this issue seems to be machine specific but I am not sure what could be causing this problem.  They were able to print all reports before without a problem and they claim that nothing different took place in the environment.

    Has anyone came upon this issue before or anyone willing to give any suggestion as to how to fix this issue?   Any input will be greatly appreciated.

    Thanks in advance.

    Lisa

    ------------------------------
    Lisa
    ------------------------------


  • 2.  RE: Printing Problems

    Posted Apr 12, 2021 03:32 AM
    Try asking another user to log into that machine and try. If  they can it's a user issue, if not it's a machine issue.
    If the latter, try re-installing the SL Client.

    ------------------------------
    Kevin Finn
    Director
    N2 End Support Services Ltd.
    London
    ------------------------------



  • 3.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 12, 2021 02:39 PM
    Kevin/Ed,

    Thanks for the input.  However, It seems like no one else could access the reports on that machine.  So the problem definitely seems like a machine specific issue.

    I indicated to them to reinstall the application, however, after the installation everything works fine but then the problem resurrected again.  Also they claim that there is no installation of any application that they are aware of that can be causing this issue.

    The other strange thing, is that they could print the 'reprint control report"  but no other reports.  

    Any further suggestions?

    Thanks

    ------------------------------
    Lisa
    ------------------------------



  • 4.  RE: Printing Problems

    GOLD CONTRIBUTOR
    Posted Apr 13, 2021 06:41 AM
    Lisa,

    Check the installed programs on the machine.  If the SAP Crystal runtime is not version 13.0.9.1312, then that is the culprit.  I recently had a company that the users started installing a Dentrix printer and Office Mate and these products installed runtime version 13.0.25.3158 and one by one the users could not print.  If the runtime version is incorrect, you will need to uninstall that and reinstall the runtime from the Prerequisites folder.
    Also, just this weekend, a user installed an Adobe update and this compromised the printing windows themselves and some windows and reports just disappeared when loading.

    Good luck,
    Dave

    ------------------------------
    David Callery
    Consultant
    Coe & Company, LLC
    Jefferson LA
    ------------------------------



  • 5.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 12, 2021 03:32 AM
    Was SAP fixed assets recently installed on that workstation? There is a conflict with crystal reports version on SAP.

    Sent from my phone, kindly overlook autocorrect or other errors.




  • 6.  RE: Printing Problems

    Posted Apr 12, 2021 03:58 PM
    Hi Lisa,

    What specifically happens when the user tries to print on the offending machine? I know you said no error message, but does ROI crash? Or the whole SL application crash? Or does it just sit there?

    Also - have you tried clicking on the blue sail button in top left > Printer Setup > and make sure Use Windows Default Printer is ticked? If not tick it and try printing again.

    Cheers,
    John.

    ------------------------------
    John Deyell
    Business Consultant
    Adaptable Consulting Limited
    auckland
    ------------------------------



  • 7.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 12, 2021 06:38 PM
    John,

    Thanks for your response.

    When they click on the report, nothing happens.  The ROI does not come up at all.  I did mention that they were able to print the AP reprint batch control report.  My guess is that this report is not using the ROI screen.   Not sure if there is a corruption of that screen that is taking place.

    They also indicated that they are using the default windows printer.  They tried changing it to print to PDF but the same behavior occurs.

    Any other suggestions?   I appreciate your assistance in this matter.

    Regards

    ------------------------------
    Lisa
    ------------------------------



  • 8.  RE: Printing Problems

    Posted Apr 12, 2021 07:54 PM
    Hi Lisa,

    Ed Leffler mentioned SAP Fixed Assets - and he's right, SAP and/or Sage Fixed Assets can cause havoc for SL users. I've never used it myself so I don't know if the symptom you are describing is what happens when that particular clash occurs.

    If you don't have either of those products, then perhaps have a look at Windows Event Viewer (applications section) and see if an error entry is created when you try to open a report that uses ROI. Depending on your SL setup you might need to do this either on the local machine or RDP server if that's how the client is delivered to end users.

    Cheers,
    JD.

    ------------------------------
    John Deyell
    Business Consultant
    Adaptable Consulting Limited
    auckland
    ------------------------------



  • 9.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 13, 2021 11:19 AM
    Hi All

    After much review with the client, they finally confirmed that they have SAGE Fixed Assets installed on the workstation.  John and Ed did mention that this could cause conflicts.

    However, since they need Fixed Assets, should they go ahead and uninstall crystal version on the machine?

    Thanks again


    ------------------------------
    Lisa
    ------------------------------



  • 10.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 13, 2021 12:12 PM
    Let me see if I can find the recommended fix and I will send you the link.

    Sent from my phone, kindly overlook autocorrect or other errors.




  • 11.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 13, 2021 01:01 PM
    I did a search for:

    "Dynamics SL" AND sage AND Crystal

    Here is the first solution I found.
    https://community.dynamics.com/sl/b/slboyerassociates/posts/dynamics-sl-and-sage-fixed-assets-2018

    There are others...


    ★★★
    Respectfully,
    Ed Leffler
    http://www.lefflerlabs.com


  • 12.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 13, 2021 02:07 PM
    Thanks Ed,

    Although the client indicated that there was no error message, I will still advise them to follow the instructions to uninstall crystal and reinstall the SL client.

    I will keep all updated on whether that was able to resolve the issue when the client give me a feedback.

    Thanks again

    ------------------------------
    Lisa
    ------------------------------



  • 13.  RE: Printing Problems

    SILVER CONTRIBUTOR
    Posted Apr 13, 2021 10:00 AM
    Lisa;

    Please have the appropriate person look on the effected machine and un-install the Crystal Runtime version that is found on that machine. 

    Then have them reinstall the Crystal Runtime software to the machine. That may correct it as I had a client with the same issue last week. 

    The software would be found in the original software media with the name of CRRuntime_32bit_13_0_9.msi

    ------------------------------
    David Safstrom
    Senior Consultant
    NexTec Group
    Roswell GA
    ------------------------------



  • 14.  RE: Printing Problems

    BRONZE CONTRIBUTOR
    Posted Apr 13, 2021 10:10 AM
    David

    Thanks for all your input,   The customer has SL 2018 CU3 installed and since crystal report does not come with that version of SL, I believe they installed crystal from their 2015 package.

    You indicated that the software would be found in the original software media.  I am  not sure what exactly you are referring to?  How do I confirm the version and runtime for Crystal?

    Thanks much.

    ------------------------------
    Lisa
    ------------------------------



  • 15.  RE: Printing Problems

    SILVER CONTRIBUTOR
    Posted Apr 13, 2021 10:28 AM

    Lisa

     

    Yes, for SL 2018 there is no full version of Crystal Reports sent with it.

     

    The reports that run within SL use the Crystal Runtime to open and print/preview the reports in the system.

     

    Look in the Uninstall Program screen in the computers Control Panel and look for the highlighted program below.

     

     

    Since you are on CU3 you will need to look at the Dynamics SL 2018 or CU1 folders to find the software to reinstall.

     

     

     

     

    Regards,

     

    David D Safstrom  |  Senior Consultant | NexTec  | Get Support

    dsafstrom@nextecgroup.comP 832.255.2822 | M 770.826.8575

     






  • 16.  RE: Printing Problems

    GOLD CONTRIBUTOR
    Posted Apr 13, 2021 10:47 AM
    Lisa,

    The runtime installed will show in the Program Files and be labeled SAP Crystal Runtime version.  It is still the same for SL2018

    ------------------------------
    David Callery
    Consultant
    Coe & Company, LLC
    Jefferson LA
    ------------------------------