Open Forum

Zero Check

  • 1.  Zero Check

    Posted 13 days ago
    Hi all

    I have a rather strange issue here and I am hoping that someone could point me in the right direction.

    A voucher was done, then it was paid.  After which the user voided the check and because they did not the voucher for that vendor, they then did a debit adjustment and then they did a zero check.

    However, when I look a the vendor maintenance screen I am seeing the balance for the vendor as -250 which is the same value for the voucher and the check.  When I look closer I am seeing that the system recorded two zero checks with the same reference numbers causing the balance to be -250.

    I then did an integrity check and the log file indicates that the extra record must be voided before it can be repaired.  I have never seen this before.  Could someone point me in the right direction to resolve this issue.

    Any assistance will be greatly appreciated.

    Thanks

    ------------------------------
    Lisa
    [
    ------------------------------


  • 2.  RE: Zero Check

    Posted 13 days ago
    Hi Lisa,

    Long time!  Did you confirm if there are actually two Zero Cheque batches and if both updated the GL (if any impact)?

    If it is actually a duplicate record and did not update the GL, you may need to delete the duplicate records from the APDoc, APTran and possibly the APAdjust tables then re-run the integrity check.

    As you know this will require a good understanding of the table structure to complete and I would recommend performing a backup before making any changes.

    regards,

    ------------------------------
    Darin Leanza
    Tucker Energy Services Holdings Limited
    ------------------------------



  • 3.  RE: Zero Check

    Posted 13 days ago
    Hi Darin,

    Yes, it has been a while; good to hear from you and thanks for the response.

    Actually what I found which is rather strange, is that it is actually one batch, same reference number etc but it is shown in the vendor maintenance screen as two separate records.    The first record is shown as -250 and the second record with the adjustment batch shown as a positive 250.    However, both have the same batch number and there are no duplicated records in the relevant tables.   This is what is puzzling me.

    So when I look at the vendor period trial balance report, the balance for that vendor is showing as -250 but the period sensitive report is showing the balance as 0.

    I know this sounds strange, but I have seen another issue where the same document was paid twice.  Not sure how did that happen. However, this was fixed and an integrity check was done.

    This same integrity check further revealed this issue which I am now trying to wrap my head around.

    Any further suggestion?




    ------------------------------
    Lisa
    [
    ------------------------------



  • 4.  RE: Zero Check

    Posted 13 days ago
    Then it might just be a duplicated APAdjust record.  I recommend looking at the details of each of the tables to confirm.

    Select * from APDoc where BatNbr = '######'
    Select * from APTran where BatNbr = '######'
    Select * from APAdjust where AdjBatNbr = '######'

    I have seen strange things like this before (not very common).   Never able to confirm the underlying cause.  That said,  if it is just a duplicated APAdjust record, should be easy to delete and re-run the integrity checks to fix the rest.

    regards,

    ------------------------------
    Darin Leanza
    Tucker Energy Services Holdings Limited
    ------------------------------