Open Forum

Crystal Reports Missing SL Specific Functions

  • 1.  Crystal Reports Missing SL Specific Functions

    BRONZE CONTRIBUTOR
    Posted 12 days ago
    Edited by Joe Miller 12 days ago
    Posting this for posterity so I can find it later and for anybody that is tired of Crystal barking about unrecognized SL functions when closing the Formula Editing window.  The specific errors you get is "The remaining text does not appear to be part of the formula." or sometimes "The ) is missing."  Both of which are very helpful!  ;)

    So we recently did an upgrade to SL 2015 and I was having troubles with editing reports in Crystal where it was not recognizing the SL specific functions.  I knew it was because I needed to reference the SL DLL that houses all the custom functions, but could not for the life of me remember where that DLL was and how to reference it.  So after a little digging, I found that you need to COPY the U2LSOL4.DLL from your SL installation Common Files to the Crystal installation folder.  On my Windows Server 2016 server those paths were:

    Source = "C:\Program Files (x86)\Common Files\Microsoft Shared\DynamicsSL\u2lsol4.dll"
    Destination = "C:\Program Files (x86)\Business Objects\BusinessObjects Enterprise 12.0\win32_x86"

    Copy (do NOT move) the DLL from the source to the destination, close and re-open Crystal and Crystal will no longer error on the SL specific formulas.  Enjoy!

    Joe

    ------------------------------
    Joe Miller
    Director of Systems Architecture
    Harrison, Walker & Harper
    Paris TX
    ------------------------------