Open Forum

Dynamics 2018 Web Apps

  • 1.  Dynamics 2018 Web Apps

    Posted Dec 12, 2018 10:07 PM
    I finally have Dynamics 2018 installed along with web services and web apps.  I have synched all employees user accounts with Project Employee Maint accounts and given all out all the necessary permissions.  The BAD thing is no one can log in!  The login screen just spits back "wrong password" after the domain accounts and passwords are correctly entered.  Any idea on how to fix this?  I also ran the .sql update scripts on the Application and System databases before attempting to log in.

    ------------------------------
    Susan Jeffries
    UNAVCO
    Boulder CO
    ------------------------------


  • 2.  RE: Dynamics 2018 Web Apps

    SILVER CONTRIBUTOR
    Posted Dec 13, 2018 02:29 AM
    Hi Susan,

    Have you tried running iisreset from command prompt?

    Marc

    ------------------------------
    Marc DeLozier
    David Evans and Associates Inc.
    Portland OR
    ------------------------------



  • 3.  RE: Dynamics 2018 Web Apps

    Posted Dec 13, 2018 09:10 AM

    Check the WebApps and WebServices logs (C:\ProgramData\Microsoft Dynamics SL) there is probably a reference to missing permissions on a stored procedure.

    The SQL Update scripts miss some of the permissions.

     

     






  • 4.  RE: Dynamics 2018 Web Apps

    Posted Dec 13, 2018 09:28 AM
    ​Have you tried running sync security in database maintenance? Also the WebApps Client and Service logs may have more information about what the issue is.

    Other things to check:
    - Trusted Web Service Account has the correct access.
    - Users have access to the correct Web Service Methods in Access Rights Maintenance.

    ------------------------------
    Lewis Shaw
    Raytheon Canada Ltd
    ------------------------------



  • 5.  RE: Dynamics 2018 Web Apps

    BRONZE CONTRIBUTOR
    Posted Dec 13, 2018 12:39 PM
    do you have the User ID populated in Empl Resource Maintenance and then the other is in Access Rights Maint: System Access

    screen shot

    ------------------------------
    Thad Vesely
    Controller
    KBA, Inc.
    Bellevue WA
    ------------------------------