Message Image  

Open Forum

Unable to Execute - System Message 5004

  • 1.  Unable to Execute - System Message 5004

    Posted 10-17-2018 03:52 PM
    Hi,

    I'm writing to see if anyone has experienced having the System Message 5004 Error on random clients and random screens. We have been getting this error for awhile now with no fix however, we recently upgraded SL2015 CU1 onto CU2 and a lot more users have been getting this error. They are unable to open the screen and/or run a process. If we uninstall/reinstall Dynamics onto the client, it fixes the issue for the time being but then it comes back later on different screens. Please help!


    SystemMessage5004

    ------------------------------
    Farhin Momin
    MCKenney's, Inc
    Atlanta GA
    ------------------------------


  • 2.  RE: Unable to Execute - System Message 5004

    SILVER CONTRIBUTOR
    Posted 10-17-2018 05:47 PM
    Hi Farin,

    I believe using REGEDIT will fix your issues....

    Use REGEDIT to do the following:

    HKEY_LOCAL_MACHINE\Software\WOW6432Node\Microsoft\DynamicsSL---> Change the INSTALLDIR and ParentDirectory entries from the UNC path to the mapped drive path

    HKEY_LOCAL_MACHINE\Software\WOW6432Node\Solomon\SolomonIV Tools for Visual Basic -->Parent Directory change the UNC path to the mapped drive path

    Reply
    Thanks,
    Michael


    ------------------------------
    Michael O'Neill
    Controller
    Eastex Telephone Cooperative
    Henderson TX
    ------------------------------



  • 3.  RE: Unable to Execute - System Message 5004

    Posted 10-18-2018 07:38 AM
    Hi Michael, thank you for that, but unfortunately I have already crossed that out. They are already set to V. Any other thoughts??





    ------------------------------
    Farhin Momin
    McKenney's, Inc
    Atlanta GA
    ------------------------------



  • 4.  RE: Unable to Execute - System Message 5004

    SILVER CONTRIBUTOR
    Posted 10-18-2018 08:13 AM
    Hi Farhin,

    Are you running Symantec on the machines?

    Thanks,
    Michael

    ------------------------------
    Michael O'Neill
    Controller
    Eastex Telephone Cooperative
    Henderson TX
    ------------------------------



  • 5.  RE: Unable to Execute - System Message 5004

    SILVER CONTRIBUTOR
    Posted 10-19-2018 06:10 AM
    We recently saw this issue on some machines at a customer we inherited.  The issue was related to some of the prerequisites not installing properly, in particular the Visual Studio elements.  I would do a complete uninstall and reinstall with making sure that the all install properly and are registered.  These can be found in the SL\Applications\PreRequisites folder.
    Application msi

    ------------------------------
    David Callery
    Consultant
    Coe & Company, LLC
    New Orleans LA
    ------------------------------



  • 6.  RE: Unable to Execute - System Message 5004

    Posted 10-19-2018 07:40 AM
    Thank you all for the feedback. It was actually our virus protection that was blocking the running of applications as it detected as malicious scripts. Thank you!

    ------------------------------
    Farhin Momin
    MCKenney's, Inc
    Atlanta GA
    ------------------------------