Open Forum

upgrade patch cannot be installed the Windows Installer service because the program to be upgraded may be missing

  • 1.  upgrade patch cannot be installed the Windows Installer service because the program to be upgraded may be missing

    BRONZE CONTRIBUTOR
    Posted 27 days ago
    I am trying to install SL client to a workstation without a previous version of SL.

    This was an upgrade from SL 2011  to SL 2018 CU4:

     

    Seems to install SL 2018 CU1 Ok then after reboot try to install SL2018_CU4.exe and it throws a new error.

     

    "The upgrade patch cannot be installed the Windows Installer service because the program to be upgraded may be missing, or the upgrade patch may update a different version of the program. Verify that the program to be upgraded exists  on your computer and that you have correct upgrade patch."  



    ------------------------------
    Mackenzie Platten
    Crestwood Associates L.L.C.
    Schaumburg IL
    ------------------------------
    Academy - Online Interactive Learning from Experts


  • 2.  RE: upgrade patch cannot be installed the Windows Installer service because the program to be upgraded may be missing

    Posted 26 days ago
      |   view attached
    Are you first installing the Dynamics SL client from within an administrative command prompt?

    If you look at the properties for the Microsoft Dynamics SL shortcut, is the path listed a mapped drive path or a local path like C:\MSDynamicsSL.exe?

    I have attached the workstation install instructions that I provide for all our clients, the paths and shares may be different in your environment but the concept should still be the same.

    ------------------------------
    Jeff Larson
    ERP Environment Specialist
    Boyer & Associates
    Plymouth MN
    ------------------------------

    Academy - Online Interactive Learning from Experts


  • 3.  RE: upgrade patch cannot be installed the Windows Installer service because the program to be upgraded may be missing

    BRONZE CONTRIBUTOR
    Posted 23 days ago
      |   view attached
    Hi Jeff,

    I am so grateful for your reply!  I have followed all of your steps.

    The attached doc shows that the error is still happening on the workstation (see screen shot on 2nd page).

    I thought if I tried to reapply the CU4 client on the server, Maybe it would refresh the install data.  I received the first error in the attached doc.

    Any other ideas?


    ------------------------------
    Mackenzie Platten
    Crestwood Associates L.L.C.
    Schaumburg IL
    ------------------------------

    Attachment(s)

    docx
    client install errors.docx   619 K 1 version
    Academy - Online Interactive Learning from Experts