Open Forum

ROI.exe crashing

  • 1.  ROI.exe crashing

    BRONZE CONTRIBUTOR
    Posted May 13, 2019 04:53 PM
    I started receiving emails that my users cannot print or print preview report in Dynamics SL 2018 CU1.  It turns out that ROI.exe is crashing on ALL workstations.  Does anyone have any ideas where to look for what is causing ROI.exe to crash?

    Thank you,

    ------------------------------
    Chris Sanderson
    Accounting Systems Administrator
    Edison Chouest Offshore
    Cut Off LA
    ------------------------------


  • 2.  RE: ROI.exe crashing

    GOLD CONTRIBUTOR
    Posted May 13, 2019 05:05 PM
    Did you recently install or update Sage Fixed Assets (FAS)?

    ------------------------------
    Jonathan Van Houtte
    Architect
    XLstatements, LLC
    Clifton Park NY
    ------------------------------



  • 3.  RE: ROI.exe crashing

    BRONZE CONTRIBUTOR
    Posted May 13, 2019 05:17 PM

    We figured it out.  It was an old issue of RptRuntime RI_ID's greater than 32,767.  Once everyone was out of SL, we deleted the records in RptRuntime and the reports are now able to be printed again.



    ------------------------------
    Chris Sanderson
    Accounting Systems Administrator
    Edison Chouest Offshore
    Cut Off LA
    ------------------------------



  • 4.  RE: ROI.exe crashing

    TOP CONTRIBUTOR
    Posted May 16, 2019 06:44 AM
    We have also found the report screen crashing because Rpt_Runtime records are not always deleted when a user closes out of the report (or even SL).  When the user relaunches the same report (meaning two Rpt_Runtime records for the same report number and report format), the can also screen error out.    We know of no other recourse than to delete the extra Rpt_Runtime error in SQL.

    Best regards,

    ------------------------------
    Gail Jones-Nemeth
    Financial Systems Analyst
    Creative Associates Int'l
    Washington DC
    ------------------------------