Open Forum

Menu Maitenance Error Message

  • 1.  Menu Maitenance Error Message

    SILVER CONTRIBUTOR
    Posted Jun 27, 2019 06:13 PM
    ​I was playing around in Menu Maintenance trying to add a custom report the menu for the "TM View" Group and I knew I wasn't doing it correctly so I closed out of the screen.  However, when I tried to go back in play again, I got this error message and it wont let me make any corrections:
    Menu Maintenance Error Message
    Any suggestions on how I can fix this?  I just want to remove it since I know I added it incorrectly but after the error message pops up, it closes the screen and wont let me make any changes.  Thank you for your help!

    ------------------------------
    Corrie Kumbalek
    GL Accountant
    KBA, Inc.
    Bellevue WA
    ------------------------------


  • 2.  RE: Menu Maitenance Error Message

    SILVER CONTRIBUTOR
    Posted Jun 28, 2019 11:21 AM

    Hi Corrie,

    Did you get this one fixed?  Which SL version are you on? I'm on SL2015 CU1 and I can't reproduce this error - I'm wondering if your SL Version has a slight bug.  It appears that the createdtype column is not being populated with any data in the query that is being run (just empty parenthesis), so the SQL run is incorrect, which is why the error is thrown:

    select * from slmenuitem where createdby= 'XTM0100' and createdtype = ()

    If you have SQL access - you could compare this record to others to see if you can spot any noticeable differences; the slmenuitem table is in the system database

    --look at all records in SL MENU
    select * from slmenuitem

    --another option is to check for missing createdtype - if you get any results, maybe populate with a 'G'?
    select * from slmenuitem
    where createdtype = ''

    --look at that createdby record to see if anything appears 'off':
    select * from slmenuitem
    where createdby= 'XTM0100'

    However, it could just be an SL bug that is not populating this field in a cursor resulting in the error.

    Good luck!
    Marc



    ------------------------------
    Marc DeLozier
    Finance SysAdmin
    David Evans and Associates Inc.
    Portland OR
    ------------------------------



  • 3.  RE: Menu Maitenance Error Message

    SILVER CONTRIBUTOR
    Posted Jun 28, 2019 02:40 PM

    ​Thank you SO much Marc!  This definitely got me on the right track to fixing it.  To create the issue, I had dragged the custom report from the menu into the Navigation Pane work area (clearly the wrong approach haha!).  Doing this had created an incomplete line that I found in the system database using:

    select *

    from SLMenuItem

    where SharedValue = 'XTM0100'



    So I deleted the line and all is good now!  I love this forum, you guys are the best!

    ~Corrie 



    ------------------------------
    Corrie Kumbalek
    GL Accountant
    KBA, Inc.
    Bellevue WA
    ------------------------------